Krytac Technical Discussion Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
mjch317

Junior Member
Registered:
Posts: 2
Reply with quote  #1 
Hey all! Fairly new to the forum, but I’m in need of some help. I recently picked up an SPR MK2 from Evike, and after a few days, pulling back the charging handle doesn’t reveal the hop up unit anymore. Although the charging handle locks in place, the hop up unit isn’t visible. The only way I can adjust the hop up is by disassembling the upper receiver from the lower. Any help?
0
Kraken_Wrangler

Avatar / Picture

Janitor
Registered:
Posts: 398
Reply with quote  #2 
You may have a bolt plate issue, or a charging handle issue. This something that can be diagnosed by removing the upper and looking inside the receiver. You should be able to see a plastic arm (KA002-21U) connected to your charging handle. This thing pulls on the metal bolt plate(KA001-07U) connected to your gearbox.

You can find these components in a breakdown inside the manual to see how they fit together.
0
mjch317

Junior Member
Registered:
Posts: 2
Reply with quote  #3 
I’ve dissassembled the receiver’s and look inside and tried adjusting the bolt plate, HopUp, etc. It seems like the bolt plate isn’t getting pulled back all the way, or perhaps maybe being blocked by something? Any idea on how to fix this?
0
Kraken_Wrangler

Avatar / Picture

Janitor
Registered:
Posts: 398
Reply with quote  #4 
Pull back the metal bolt plate and see if it locks in the gearbox. If it does, then you may have an issue in the upper.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.