Krytac Technical Discussion Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 2 of 2      Prev   1   2
JonDewhirst

Junior Member
Registered:
Posts: 11
Reply with quote  #16 
Quote:
Originally Posted by Adrian Whiting
Hello Jon,

Sorry to hear you don’t have a fix just yet. I appreciate you will try and sort the chrono testing KW has suggested above but it may just be worth making sure that you haven’t lost the spring (part KAO18 10U on the diagram in the library here), that sits around the outer barrel. In another thread someone has had similar velocity problems and the cause was a missing spring.

Just a thought,

Adrian


I took it apart twice at the field to make sure everything was in the right place and clean. Both springs were where they should be.

:0(
0
JonDewhirst

Junior Member
Registered:
Posts: 11
Reply with quote  #17 
So. Put in a new bucking. Prometheus purple.

FPS is now stable, about 296 with 0.25gm BBs.

BUT to get the hop effect I need, I have to crank the hop up to 15. Played last weekend in the cold and it was under hopped. I’m putting this down to hop design and nub size.

We’re gonna need a bigger nub.

Any ideas? I know the hop unit / nub is proprietary so wat can be done?
0
Kraken_Wrangler

Avatar / Picture

Janitor
Registered:
Posts: 398
Reply with quote  #18 
The nub may be proprietary, but the hopup arm is not. It'll fit any normal nub, the arm just won't retain when you open it for servicing.
0
JonDewhirst

Junior Member
Registered:
Posts: 11
Reply with quote  #19 
Quote:
Originally Posted by Kraken_Wrangler
The nub may be proprietary, but the hopup arm is not. It'll fit any normal nub, the arm just won't retain when you open it for servicing.


Lovely. Thanks for the info.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.